Free Premium Softphone Software2.0 - Download
You'll be able to download in few seconds.
Publisher Description
Premium Features:
4 Lines,Call Recording,Hold / Unhold ,Transfer (Xfer),DND (Do not Disturb),Redial,Mute,Auto accept call,NAT/Firewall support
STUN server Support ,ICE Support,Debug Mode (SIP message log),Codec Supported,G729, G711 u, G711 a, G722, GSM, iLbc, Speex/ 8000, Speex/16000 , Speex / 32000,Codec selection and Codec Quality Control (Bandwidth control),Silence Suppression,Echo Cancellation
Uses NEW RFC 3261 compliant stack,DTMF (RFC 2833),RFC 3951: Internet Low Bit Rate Codec (iLBC),Proxy Settings,Registration Timeout
Acoustic Echo Cancellation,Packet concealing,Packet Lost Concealment (PLC),Comfort Noise Generator (CNG),Resampling,Balance Display
Credit time display.
Basic Features:
Customized skin interfaces ,Call timer ,Last Number Redial ,Touch Tone ,Address Book ,Micro Phone Volume Control ,Speaker Volume Control ,Work with any full-duplex sound card ,Auto-configuration of settings for easy deployment
About Free Premium Softphone Software
This Telephony program is available in English. It was last updated on 29 September, 2026. Free Premium Softphone Software is compatible with the following operating systems: Windows.
The company that develops Free Premium Softphone Software is Adore Infotech. The latest version released by its developer is 2.0.
The download we have available for Free Premium Softphone Software has a file size of N/A. Just click the green Download button above to start the downloading process. The program is listed on our website since 2008-07-08 and was downloaded 0 times. We have already checked if the download link is safe, however for your own protection we recommend that you scan the downloaded software with your antivirus. Your antivirus may detect the Free Premium Softphone Software as malware if the download link is broken.
How to install Free Premium Softphone Software on your Windows device:
- Click on the Download button on our website. This will start the download from the website of the developer.
- Once the Free Premium Softphone Software is downloaded click on it to start the setup process (assuming you are on a desktop computer).
- When the installation is finished you should be able to see and run the program.
Program Details
System requirements
Download information
Pricing
Version History
version 2.0
posted on 2008-07-08
Vista Support
Disclaimer
External Download
We do not host Free Premium Softphone Software on our servers. We did not scan it for viruses, adware, spyware or other type of malware. This app is hosted by the software publisher and passed their terms and conditions to be listed there. We recommend caution when installing it.
The external download link for Free Premium Softphone Software is provided to you by apps112.com without any warranties, representations or guarantees of any kind, so access it at your own risk.
If you have questions regarding this particular app contact the publisher directly. For questions about the functionalities of apps112.com contact us.
